How to configure static routing on 4 routers?

How to configure static routing on 4 routers and more? In the previous article of static routing, we have learned the simple static routing on routers. Now in this lab, we learn how to configure static routing on more than two routers so that can help you in learning how you can configure static routing on as many routers as you wish. We have one another lab here to learn static routing perfectly. By learning CCNA you can find a job in a leading IT company and earn money from that place. So let’s start routing from a lab in cisco packet tracer.

configure static routing on 4 routers

Want to learn Linux and searching for a start then Here is our guide on some basic but important Linux commands that everyone should know.

Follow below-given steps and codes to configure static routing on the router and repeat it on for more than 4 routers also.

1. Configure routers such as assigning IP addresses to the available ports and activate them.

For Router r1

--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname r1
r1(config)#
r1(config)#interface FastEthernet0/0
r1(config-if)#ip address 1.0.0.1 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
r1(config-if)#exit
r1(config)#interface FastEthernet0/1
r1(config-if)#ip address 4.0.0.2 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
r1(config-if)#exit
r1(config)#interface Ethernet0/0/0
r1(config-if)#ip address 5.0.0.1 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#
%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up
r1(config-if)#exit

For Router r2

Press RETURN to get started!
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname r2
r2(config)#
r2(config)#interface FastEthernet0/0
r2(config-if)#ip address 1.0.0.2 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
r2(config-if)#exit
r2(config)#interface FastEthernet0/1
r2(config-if)#ip address 2.0.0.1 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
r2(config-if)#exit
r2(config)#interface Ethernet0/0/0
r2(config-if)#ip address 6.0.0.1 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#
%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up
r2(config-if)#exit

For Router r3

Press RETURN to get started!
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname r3
r3(config)#
r3(config)#interface FastEthernet0/0
r3(config-if)#ip address 3.0.0.1 255.0.0.0
r3(config-if)#no shutdown
r3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
r3(config-if)#exit
r3(config)#interface FastEthernet0/1
r3(config-if)#ip address 2.0.0.2 255.0.0.0
r3(config-if)#no shutdown
r3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
r3(config-if)#exit
r3(config)#interface Ethernet0/0/0
r3(config-if)#ip address 7.0.0.1 255.0.0.0
r3(config-if)#no shutdown
r3(config-if)#
%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up
r3(config-if)#exit

For Router r4

Press RETURN to get started!
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname r4
r4(config)#interface FastEthernet0/0
r4(config-if)#ip address 4.0.0.1 255.0.0.0
r4(config-if)#no shutdown
r4(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
r4(config-if)#exit
r4(config)#interface FastEthernet0/1
r4(config-if)#ip address 3.0.0.2 255.0.0.0
r4(config-if)#no shutdown
r4(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
r4(config-if)#exit
r4(config)#interface Ethernet0/0/0
r4(config-if)#ip address 8.0.0.1 255.0.0.0
r4(config-if)#no shutdown
r4(config-if)#
%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up
r4(config-if)#exit
r4(config)#

Now all ports are up and running from all the routers and IP addresses are also assigned on all interfaces of the routers. Always remember to change IP addresses according to your need here I use IP addresses only for examples.

If you don’t know about the basics of static routing then read my previous article on static routing. apart from this basic configuration on switches is also a good topic to learn.

2. Configure static routing on all routers by following given below steps

For Router r1

r1(config)#ip route 2.0.0.0 255.0.0.0 1.0.0.2

r1(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

r1(config)#ip route 6.0.0.0 255.0.0.0 1.0.0.2

r1(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

r1(config)#ip route 8.0.0.0 255.0.0.0 4.0.0.1

For Router r2

r2(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

r2(config)#ip route 4.0.0.0 255.0.0.0 1.0.0.1

r2(config)#ip route 5.0.0.0 255.0.0.0 1.0.0.1

r2(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

r2(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

For Router r3

r3(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.1

r3(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

r3(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.2

r3(config)#ip route 5.0.0.0 255.0.0.0 1.0.0.1

r3(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2

For Router r4

r4(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.2

r4(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2

r4(config)#ip route 6.0.0.0 255.0.0.0 1.0.0.2

r4(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

r4(config)#ip route 7.0.0.0 255.0.0.0 3.0.0.1

Now static routing is configured on all the routers to check if the routing is placed successfully or not use ping command from one of the PCs and try to communicate with another. want to know how to configure IP addresses on the PCs then check our previous article.

3. Check the connection using ping command

Here we try to communicate pc0 to pc3 and results and codes will be shown below. refer to the figure to confirm which is pc0 and which pc3.

PC>ping 6.0.0.2
Pinging 6.0.0.2 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 6.0.0.2:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
PC>
PC>ping 6.0.0.2
Pinging 6.0.0.2 with 32 bytes of data:
Request timed out.
Reply from 6.0.0.2: bytes=32 time=1ms TTL=125
Reply from 6.0.0.2: bytes=32 time=0ms TTL=125
Reply from 6.0.0.2: bytes=32 time=0ms TTL=125
Ping statistics for 6.0.0.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

Here two outputs are shown above in which on the first output it didn’t connect with other pc but when we try for the second time it communicates perfectly with the pc which is present in another network.

THAT’S IT

Comment your thoughts.

You may also like...

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: